Yay security!

I’ve updated my site with a SSL certificate. I feel so proud that I did it mostly by myself. I had some help from a friend on IRC because i forgot to poke a few holes in my firewall. But now, everything is connected, and the traffic on this site is now encrypted!

Except for my ZNC web panel. Unfortunately I think i fucked it up. I’ll figure it out eventually, but for now, it’s still going through my unencrypted service.

While writing up this post, I was…enlightened by another IRC user that I shouldn’t be using Apache for my webserver. I’ve since switched to Nginx which was an ordeal itself. The migration process is not a 1:1 conversion, and many things had to be re-kajiggered to work right.

In particular, it took me ages to get the PHP working again on the site. Apparently the config that came from one tutorial was too complex for what I needed, and was causing issues. I’ve got no idea why, since I can’t understand the options anyway.

Regardless, things seem to be back up and running. Now if only I could get that ZNC web panel working like it should…

“I’m not a weeb.”

“You should watch X show, it’s pretty nice”

“Nah, I’m not a weeb

 

This annoyed me recently. Mostly because it’s completely dismissing an entire subgenre of an art style simply because of where it originated from. In my mind this is almost akin to racism. “I don’t like that type of art style because the Japanese made it originally.”

I’m not a fan of racism in the most lenient of situations. Even this is probably the most subtle form of racism because one could do this even without expressing your own views to another party. And I get it-one’s preferences is one’s preferences. But when you tell me that you refuse to even experience a certain media because of it’s influence or where its influence comes from, that annoys the shit outta me.

God forbid that you expand your artistic horizons, and learn more about how a large portion of the world enjoys art.

Back in action!

So a few weeks ago, Gloria suffered a hardware failure on her motherboard. It seems that there was some sort of issue that eventually prevented the motherboard from POST-ing. This unfortunately caused the server to lock up unexpectedly, and of course took down everything I had on it.

So I submitted a warranty request to ASUS, and after discussing the issue with them, I was eventually able to submit a RMA request with them. For some reason however, ASUS’ technical and warranty support seem almost archaic. Web forms submitted to a direct email, with incredibly poor HTML formatting on the replies make me wonder if their support is outsourced.

But thankfully, the system worked, and I was able to get a replacement motherboard sent to me, and I just plugged everything back in and powered Gloria up. Thanks to my settings with fstab ages ago, I didn’t have to worry what ports the various hard drives were plugged into in order to ensure it booted properly. All of my drives are indexed by UUID rather than port number, so even my network shares are back where they should be without having to worry about changing settings again.

Now all I have to worry about is updating things since the downtime. Otherwise, it’s game on for anything else.